Jetboot fährt Schlangenlinien mit APM

tkt2208

Neuer Benutzer
#81
Ich steuere das Boot auch nur mit einem Knüppel auf der Fernbedienung. Linker Knüppel auf der Fernbedienung für Gas und Lenkung, Kanal 3 und 4. Das funktioniert soweit auch alles problemlos.

Nur der Autopilot will noch nicht so wie ich will.

Navl1period steht aktuell auf 20. habe alle anderen möglichen Werte versucht aber bei 20 ist meiner Meinung nach am besten doch trotzdem drehen die beiden Motoren abwechselt hoch und runter. Linker Motor schnell rechter Motor langsam und eine halbe Sekunde später umgekehrt und dadurch entsteht keine saubere fahrt sondern das Boot eiert sich zum Ziel.
 

tkt2208

Neuer Benutzer
#85
Kurvenradius ist so eine Sache wenn ich den Knüppel nur nach links oder rechtes bewege ohne dabei den Knüppel nach vorn oder hinten zu drücken dreht das Boot auf der Stelle. Was gebe ich da für einen Kurvenradius ein ?
 
G

Gelöschtes Mitglied 1973

Gast
#86
1 Meter passt meistens, hat du "pivot turn" akitiviert?
dann dreht der autopilot auf der stelle!
 

tkt2208

Neuer Benutzer
#91
Es hat heute bei uns den ganzen Tag geregnet somit konnte es nicht testen. Ich melde mich sobald ich es testen konnte um meine erfahrungen zu berichten.

MfG der tkt
 

tkt2208

Neuer Benutzer
#92
Es ist vollbracht :eek:
ich habe die passenden Werte für mein Boot gefunden :D

Ich bin wie folgt vorgegangen:

Als erstes habe ich den APM mit der Rover Firmware neu geflasht um alle Parameter auf Standart zu bekommen. Da ich mir nicht mehr sicher war wo ich überall etwas verändert habe.

Danach habe ich den Wizard für den Rover vollständig durchgeführt.

Mit Hilfe der von LARZ verlinkten Anleitung bin ich durch Probieren auf folgende Werte gekommen.

STEER2SRV_P -> 0.2
CRUISE_SPEED -> 2
CRUISE_THROTTLE -> 80
TURN_MAX_G -> 2
SPEED_TURN_GAIN -> 50
NAVL1_PERIOD -> 25

Nun fährt das Boot Schnurstrax auf das angegebene Ziel zu und das ohne zu eiern :)

VIELEN DANK LARZ FÜR DEINE HILFE

Aber eine Kleinigkeit habe ich dann doch noch :rolleyes:

Wenn das Boot am Ziel angekommen ist schalten die Motoren ab -> alles richtig
Das Boot treibt aber logischerweise noch weiter.
Gibt es eine Möglichkeit den Schub der Motoren vor dem Ziel schon zu verringern um dies bestmöglich zu verhindern ?


MfG der tkt
 

Larz

Erfahrener Benutzer
#93
Na astrein, tkt!

Das mit dem Treiben ist kein Problem! Du musst den Radius des Wegpunktes auf ca. 5m stellen. Das ist in etwa die Drift-entfernung bis zum Spot! Ich glaube "Waypointradius" heißt der Parameter. Versuch mal!

Freut mich, dass es bei dir jetzt funktioniert!

PS: Irgendwie schickt mir das Board hier keine Mail wegen neuem Beitrag, sonst hätte ich schon eher geantwortet! Muss ich mal gucken, was da nu wieder los ist..
 
Zuletzt bearbeitet:
#94
Hallo zusammen,da ich auch noch in der Einstellphase des Automodus bin habe ich den Thread gespannt verfolgt .Welche Firmware vom Rover habt Ihr denn benutzt? Ich hatte mit der neusten immer etwas Probleme und bin auf die letzte 2.46 ausgewichen die ganz gut funktionierte.Leider habe ich das Problem auch mit dem Automodus bzw. dem RTL.Manuell funktioniert es gut.
Boot hat leider Bürstenmotoren die ich jetzt aber entstört habe und gurkt merkwürdig umher.Werde jetzt mal die Daten vergleichen und dementsprechend ändern.Muß die Einstellung denn Roll 180° sein, wenn der Ublox "ganz normal" angebracht ist LED oben ,Prozessor unten?
Danke für Hilfe MfG Voodoo
 
#96
Hallo TKT,Danke erstmal für Deine Antwort.Ja da scheint schonmal ein Fehler zu liegen.Also habe ich als Kontrolle mein Handy auf 0° N ausgerichtet (zum Boot parallel).Mission Planner zeigte dort irgendwas im NE Bereich an.Also habe ich nochmals gelesen und mir den Einbau vom GPS/Kompass Modul angeschaut.Dort stellte ich fest das ich (warum auch immer) das Teil 45° nach links verdreht eingebaut habe.Ich komme da ohne größeren Aufwand nicht mehr dran.Das sollte jedoch kein Problem sein,da es ja genügend Einstellungen gibt um das zu kompensieren.(hoffe ich)
Also eingebaut ist es so(siehe Bild)Normalerweise müßte ich dann der Einstellung sagen Rotation 45° Yaw oder?Das werde ich jetzt mal testen,berichte weiter.Grüße Voodoo Compass.jpg
 
#97
So erster Nachtrag:Kompass Rotation auf 225° Yaw .Nun fängt jetzt die Yaw-Anzeige im Mission Planner an zu "wandern" in Richtung + Also hat bei 0 Grad angefangen und läuft mit ungefähr 0,1Grad /sekunde aufwärts......Hmmm Boot steht aber still und Kompassrose im Missionplanner wandert mit.


So:Bei diesem Modul Frontseite LED links oben somit schwarzes SMD rechts oben
 
Zuletzt bearbeitet:

tkt2208

Neuer Benutzer
#98
Hallo Voodooman,

da der Kompass beim Ublox GPS Modul auf der Unterseite der Platine verbaut ist steht dieser auf dem Kopf aus diesem Grund muss aus meiner Sicht die Einstellung auf Roll 180 gestellt sein. Wenn du die Einstellung Yaw tätigst korrigierst du nicht die Kopfstellung des Kompasses.

Hier mal ein Bild zur Veranschaulichung



Mfg der tkt
 
Zuletzt bearbeitet:
#99
Hallo TKT, Ja das mag so sein doch das meiste bezieht sich auf den Quadkopter ,wo dies die Einbaulage so erfordert.Wenn Du recht hast und dem Kompass das egal wäre,wofür gibt es dann die vielen anderen Einstellungen zur Kompassorientierung.
Die andere Seite ist , dass bei Automatik GPS Steuerung der Kompass vollkommen egal ist bzw ignoriert wird zur Steuerung.Das kann man aber ein bzw ausschalten.Doch GPS Steuerung ist wichtiger.
Habe schon Vollgas mit Motoren gefahren ,aber das Magnetfeld bleibt ruhig.Das heißt eigentlich das keine Störungen das Modul beeinflussen. Ich muß einfach nochmal ans Wasser und fahren bzw mit aktiven GPS probieren ob sich da was ändert .Ich berichte wieder.Danke Voodoo
 
Also es wird immer komischer.Hätte da mal ne Frage :Wenn das externe GPS/Kompassmodul abgestöpselt ist und ich die APM2.6
rechts links drehe bewegt sich auch der Horizont sprich Nord Ost West Süd. Sollte denn der 2.6 kein Kompassmodul mehr haben? Oder hab ich da einen Denkfehler .......dreh noch durch
 
RCLogger

FPV1

Banggood

Banggood

Oben