KK2.0 LCD mit OpenAero2 zur Flugstabilisierung

Florian88

Neuer Benutzer
#61
Habe soweit alles hinbekommen,nur korrigieren die Qerruder falsch,d.h. wenn ich den flieger nach rechts neige geht das rechte Querruder nach oben und umgekehrt.Wo kann ich da was einstellen?Wenn ich Stabilisierung bzw. Auto-Level abschalte ist alles OK.
Will sagen,am Sender ist alles richtig eingestellt.
Hallo coolschuetz,
das gleiche Problem wie du es hast hatte ich auch. Im "Channel Mixing Menu" kannst du - wenn du etwas nach unten scrollst - die Gyro-Richtung ändern. Wenn du das geändert hast sollte es richtig funktionieren.

Aber an den Rest der Truppe hier habe ich auch noch eine Frage.
Das Board setze ich aktuell in meiner Funcub ein.
Welche Werte für die PID-Werte Roll, Pitch und Yaw habt ihr denn so eingestellt und erflogen?

Ich hatte das Problem, dass mir die Funcub extrem weggestiegen ist, wenn ich mehr Gas gegeben habe. Dies ist nun nicht mehr der Fall. Fliege ich nun eine Rolle kommt es mir vor als ob keine bis wenige Stabilisierung um die Querachse stattfindet. Ist das bei euch auch so? Da hätte ich noch gerne mehr Stabilität um die Querachse.

Grüße Florian
 
Zuletzt bearbeitet:

Heliflieger

RotorCross-Flieger
#62
Welche Werte für die PID-Werte Roll, Pitch und Yaw habt ihr denn so eingestellt und erflogen?

Ich hatte das Problem, dass mir die Funcub extrem weggestiegen ist, wenn ich mehr Gas gegeben habe. Dies ist nun nicht mehr der Fall. Fliege ich nun eine Rolle kommt es mir vor als ob keine bis wenige Stabilisierung um die Querachse stattfindet. Ist das bei euch auch so? Da hätte ich noch gerne mehr Stabilität um die Querachse.
Hallo, Florian!

Ich fliege meine Modelle alle mit der Grundeinstellung der PID-Werte.

Wenn dein Modell beim Gas geben hoch steigt, hat das nur in sofern mit dem KK-Board zu tun, dass es scheinbar nicht ganz in der Fluglinie liegt und beim Aktivieren gleich etwas Höhe einstellt.

Das kann (und muss) man dann im Board wegtrimmen - Nicht am Sender. Ich hatte das bei meiner Fox.
Nicht vergessen: Trimmungen am Sender bringen nur für einen Flug etwas, weil das Board die Grundeinstellungen herstellt und die Trimmungen vom Sender so weg nimmt.
 

Rick S

Erfahrener Benutzer
#63
Hi!

Ich hatte meinen ersten Flug mit dem KK2.0 OpenAero 1.1.1
Ich war aber alles andere als begeistert. Beim ersten Versuch die Stabilisierung zu nutzen fingen die Querruder an zu zucken. Beim zweiten Mal, also nachdem ich einen neuen Akku drin hatte, fing das Hohenleitwerk an zu zucken.

Kennt wer das Problem?
Ich habe alle Einstellungen noch auf standard.
Das KK2 ist in einer Yak54, 11,5m Spannweite.
 
#64
11,5m ist wohl etwas übertrieben.Vielleicht sollte mal jemand,bei dem alles funktioniert seine Einstellungen vom KK2 hier posten.
Bei mienem Easyglider zucken die Servos auch und die Ruderausschläge sind sehr klein.
 

Heliflieger

RotorCross-Flieger
#67
Das KK2 ist in einer Yak54, 11,5m Spannweite.
Das Board ist nicht für manntragende Flugzeuge gedacht ;)
Sorry, ich konnte nicht widerstehen.

Spaß beiseite.
Du solltest die Servoeinstellung(Taktung) und die Empfängereinstellungen(richtiger Empfänger eingestellt?) prüfen.
Ggf. ist da etwas falsch konfiguriert und das kann zu Zittern der Servos führen.
 

Heliflieger

RotorCross-Flieger
#69
Hallo!

Leider hab ich im Moment wenig Zeit.
Vielleicht probierst du mal deinen Empfänger ohne Satellit.
Wenn möglich, das Board mal in ein anderes Modell bauen.
Halt einfach versuchen, durch Komponententausch den Fehler einzugrenzen.

Ich selbst fliege Jeti und stellte keine Probleme fest.

Dann gibt es ja noch neuere Firwares, als die 1.1.1. Die kannst du auch mal Testen, aber vorsicht: Beta-Status!
http://www.rcgroups.com/forums/showthread.php?t=1708175

Alternativ schau hier mal nach, ggf. hilft das weiter:

http://code.google.com/p/nextcopterplus/wiki/OpenAero2_UserGuide_V1
http://code.google.com/p/nextcopterplus/wiki/OpenAero2_Adv_UserGuide_V1

Meine versprochene DEUTSCHE Anleitung ist schon in Arbeit, aber momentan habe ich wirklich zu wenig Zeit.
 

Mc Lovin

Neuer Benutzer
#70
hallo,

UPDATE:

habe mein board jetzt mit OpenAero2v1.2beta8 geflasht und in einem nuri verbaut. stabi und autolevel laufen parallel und sauber miteinander.
diese betaversion läuf bei mir ohne probleme!

grüsse
 
#71
Thema Anschluss:

Das Board wird vom Empfänger mit Strom versorgt.
ABER die Servos nicht!
Daher muss es nochmal mit 5-6V versorgt werden, damit die Servos Strom haben.

Der Servostecker von diesem BEC/Motorregler kommt dann auf den 2. Steckplatz von vorn rechts.
(hinten sind die vier Knöpfe. Links und recht sind die Steckerleisten; Bild kommt noch)


Jetzt die Anschlußseite der Servos (rechte Steckerleiste mit 8 Steckplätzen,)
Von vorn nach hinten: 1.leer, 2.BEC/alter Motorregler, 3.+4. leer (kommt später), 5. Höhenruder, 6. linkes Querruder, 7. rechtes Querruder, 8. Seitenruder.
Hallo Heliflieger,

vielen herzlichen Dank für die tollen Berichte über die Möglichkeit der KK2 Board Verwendung mit Open Aero2.
Da ich nun auch diese Board (auf Grund Deiner Berichte) zu dieser Verwendung im Flächenflieger einsetzen werde,bin ich nun etwas irritiert,was die Boardanschlüsse betrifft,insbesondere nach Studium der fast 180 Seiten auf http://www.rcgroups.com/forums/showthread.php?t=1708175.
Dort wird fast immer die Notwendigkeit der Belegung des M1 Ausgang mit der ESC Spannung (rechte Board Seite der 8Pin Reihe) berichtet,da hierüber das Board mit 5V versorgt wird.
M2 Pin des Board's bedarf einer eigenen Spannungsquelle 5V zur Servoversorgung.
Wichtig:
Da i.d.R. ja der RX aus dem Regler (ESC) mit ca.5 V durch den Gaskanal versorgt wird,liegt an allen Empfängerausgängen bereits diese Spannung an ,welche nach meiner Auffassung damit auch das gesamte Board mit 5V versorgt,sobald Quer,Seite u.Höhe-Achse an die linke Board Seite (5er Pin Reihe) angeschlossen werden.
Daher ist es unbedingt erforderlich den Pin M1 frei ohne jegliche Zusatzspannungsversorgung zu lassen,da ansonsten u.U. das Board "geröstet" wird.Dies geht aus keiner Beschreibung eindeutig hervor !

Dein Hinweis M2 Ausgang mit externem "amputiertem" Regler mit 5V zur Gesamtversorgung der Servo-Anschlüsse M3-M8 mit 5V ist o.K....aber kann man sich dies nicht evtl.ersparen durch einen Servosteckerabgriff aus einem freien RX Kanal (welcher je bereits 5V hat) und diesen nach Ausgang M2 anschliesst ? Damit wäre das weitere ESC zur M2 Versorgung eingespart.

Evtl.habe ich ja einiges nicht richtig verstanden bei der Boardkonfiguration, bzw.aus engl.Übersetzungen falsch interpretiert. ??
 

Wowbagger

Erfahrener Benutzer
#72
Gestern habe ich endlich mein KK2-Board bekommen. :)

Jetzt überlege ich, in welches Modell ich das zum Testen einbauen soll. Sehr wahrscheinlich wird es ein 3-Achs-Motorsegler werden, bei dem beide Querruder auch einzeln vom Empfänger angesteuert werden, um Spoiler als Landehilfe nutzen zu können.

Jetzt sind noch ein paar Fragen aufgetaucht:

1. OpenAero?
Hier im Thread geht es natürlich um OpenAero. Jetzt ist in der Original-Firmwar auch schon ein Modus für Flächenflieger drin. Was sind eigentlich die wesentlichen Vorteile von OpenAero?

2. Spannungsversorgung
Bei den ins Auge gefassten Modellen habe ich üblicherweise nur das BEC vom Motorregler für Empfänger und Servos genutzt. Jetzt steht im Wiki drin, dass man möglichst die Servos (M2-M8) über ein getrenntes BEC betreiben soll, damit die Spannungsspitzen durch die Servos keine Auswirkung auf das Board haben, d.h. z.B. Brownouts vermieden werden. Das gleiche kenne ich vom APM und habe dort tatsächlich zwei verschiedene BECs im Einsatz. Wie macht ihr es? Nutzt ihr auch beim KK2-Board zwei getrennte BECs für Servos und Rest? Habt ihr Erfahrungen, ob das wirklich in der Realität problematisch ist?

3. Motor
Steuert OpenAero auch den Motor an, um z.B. Höhe zu halten? Oder wird der Motor ganz normal am Empfänger angeschlossen und das Board steuert nur die Servos?
 

Heliflieger

RotorCross-Flieger
#73
Zu 1:
Probier's einfach mal aus und berichte.

Zu 2:
Einen alten Motorregler parallel an den Akku hängen. Die Motorkabel einfach abschneiden oder ablöten etc.

Zu 3:
Nein! Motor wird nur durchgeschleift und nur, wenn man einen Satellitenempfänger benutzt.
Wenn du einen normalen Empfänger hast, dann schließt du den Motor, wie gewöhnt an deinem Empfänger an.
 

Wowbagger

Erfahrener Benutzer
#74
Zu 1:
Probier's einfach mal aus und berichte.
Ich dachte, dass da evtl. schon was bekannt ist.

Zu 2:
Einen alten Motorregler parallel an den Akku hängen. Die Motorkabel einfach abschneiden oder ablöten etc.
Ich habe auch noch kleine UBECs hier rumliegen, die sind kleiner als ein alter Regler. Das ist kein Problem.
OK, d.h. Du nutzt es also tatsächlich mit zwei BECs. Hast Du da negative Erfahrungen mit einem gemacht oder außerhalb der Anleitung von gelesen?

Zu 3:
Nein! Motor wird nur durchgeschleift und nur, wenn man einen Satellitenempfänger benutzt.
Wenn du einen normalen Empfänger hast, dann schließt du den Motor, wie gewöhnt an deinem Empfänger an.
Ah, ok. Dann reichen die Eingänge für 2 getrennte Querruder.
 

Heliflieger

RotorCross-Flieger
#75
Ich selbst habe die Originale Firmware auf dem KK 2.0 nie für Flächenansteuerung benutzt.

Bei mir sind zwei Modelle mit KK 2.0, OpenAero und ausgedienten BECs ausgerüstet. Funktioniert problemlos.
Die Stromstärke sollte aber für wenigstens 4 Servos geeignet sein, was wohl mit den meisten BECs geht.
 

fpvchri s

Erfahrener Benutzer
#76
Hallo,

Ich habe meine twinstar auch mit dem kk2.0 und open aero v 1.1.1 ausgestattet.
Vorteil bei der twinstar ist, ich Hab schon 2 Regler drin und muss nicht extra noch einen reinbauen für die Stromversorgung der servos.

Ich hatte am Anfang Probleme die wirkrichtung der gyros einzustellen. Aber nach ein wenig rumprobieren hat's geklappt. Was soll ich sagen?! 1a! Funktioniert super. Ich fliege das kk auch auf dem copter und bin begeistert das dieses Board auch für Flächen genutzt werden kann.

Hat jemand von euch neuere fw drauf und kann dazu etwas sagen? Bin mit der 1.1.1 eigentlich ganz zufrieden.
 
#77
Hallo,

habe auch gerade ein kk2.0 in meinen Nuri eingebaut und teste derzeit noch im Trockentraining. Wenn ich alle Stabi-Sachen ausschalte und die Knüppel bewege, laufen die Servos teilweise ruckartig.
Kann das wer bestätigen?
Empfänger ist ein Frsky mit Summensignal.

Danke.
Grüße Erwin
 

Heliflieger

RotorCross-Flieger
#78
@fpvchris
Wie ist das zu verstehen, dass du für das Board keine Stromversorgung brauchtst?
Die beiden Regler sind ja meines Wissens im Empfänger eingesteckt und regeln die beiden Motoren deines Twinstars.
Wie bekommt nun dein Board die Stromversorgung für die Servos?

@Erwin
Da stimmt etwas mit der Servotaktung nicht.
Vermutlich stimmt sie im Board, aber nicht im Empfänger selbst.
Leider kenne ich aber den Empfänger nicht. Da her ist es nur eine Vermutung.
 

fpvchri s

Erfahrener Benutzer
#79
Ich hab die Signalleitungen der Regler zusammengelötet und diese werden zusammen in den Empfänger geführt, dass beide motoren zusammen geregelt werde. Das + und - das übrig bleibt habe ich dann in den m2 slot des kk boards gesteckt. so versorgt der eine regler empfänger und der andere die servos.
 
#80
@erwin
da stimmt etwas mit der servotaktung nicht.
Vermutlich stimmt sie im board, aber nicht im empfänger selbst.
Leider kenne ich aber den empfänger nicht. Da her ist es nur eine vermutung.
An Servotaktung habe ich auch gedacht, im Board ist sie auf LOW und ändern auf HIGH hat auch nicht´s gebracht. Am Empfänger ist da nicht viel einzustellen.
Vielleicht sollte ich mal ein anderes Servo probieren..........
 
RCLogger

FPV1

Banggood

Banggood

Oben