RadioMaster R168 Receiver

Bussard

Erfahrener Benutzer
Jo, schau mal bei #1 und #98 und #99.

Für diejenigen, die dieser Tage den ersten R168 erhalten haben, kann es eventuell nützlich sein, Beitrag #10 und #14 anzusehen und zu lesen, ehe der Receiver beim Probieren stirbt.
 
Zuletzt bearbeitet:
Heute sind bei mir auch 2 Stck. eingetrudelt, nach Tracking am 20.10. in EU gelandet, aus NL verschickt und vom Frankfurter/M. Flughafenzoll abgefertigt. Nicht ganz verwunderlich klebte dieser Aufkleber auf dem typischen Folienbeutel:

Anhang anzeigen 183118


Erster Eindruck:
- gut sitzendes Gehäuse mit 2 vorbildlichen Gummi-Antennen-Herausführungen als Knickschutz
- die "dicken" Antennentöpfe vom Webseitenfoto entpuppen sich als nur 3.5mm dünne Röhren, das ist viel weniger als angenommen und lässt sich sicher einigermaßen unterbringen

Da das Beiblatt ("R168 Receiver User manual") schon ergänzt wurde, (Ub max von 6V auf 8.4V erhöht sowie der Punkt Spannungsmessung hinzugefügt), ist schön. Noch besser wäre eine Revisionsverwaltung mit Hardwarebezug und Softwarestand bei Einführung oder zumindest das Datum der Inkraftsetzung. Man darf sich ja was für die Zukunft wünschen ;) . Ich habe beide Beiblätter angehängt.

Die Stromaufnahme mit/ ohne Telemetrie sagt eine Menge über die Telemetrie-Sendeleistung aus, habe ich hier gelernt. So war meine erste Messung die der Stromaufnahme im Betriebspannungsbereich ohne und mit Telemetrieübertragung:
Anhang anzeigen 183121
Soweit bisher, Gruß Bussard
Hallo, ich hätte eine Frage zu dem Radiomaster R168 Enpfänger. Ich habe mir einen über ali bestellt aber ich kann ihn nicht mit meiner FrSky X9D+ V1 binden. Ich habe versucht die Firmware des R168 über die Taranis zu flashen auf LBT V1 aber da kommt eine Fehlermeldung.
 

Bussard

Erfahrener Benutzer
Die R168 lassen sich von der Funke aus einwandfrei mit den 4 verfügbaren Firmwares flashen.

Hast Du schon mal mit dieser Konfiguration von Sender und Flashkabel einen X8R oder anderen FrSky-Receiver geflasht?
 

WilliP

Neuer Benutzer
Bei mir war es aber so, dass ich den Empfänger nur mit der FCC V1 Firmware voll nutzen kann:
2 Empfänger binden für 16 Servosteckplätze oder beim Binden Kanäle 9...16 auswählen für Servosteckplätze (Kanäle 1...8 S-Bus).
Mit den anderen 3 Versionen war so was nicht möglich.
 
Bei der Kombination des R168 ( an SPort ) an RadioMaster Tx16s mit dem openXsensor-Vario erhalte ich zumindestens in meinem Bastelzimmer schon nach spätestens 1 Minute regelmäßig die Ansage "Sensor verloren". Nach Neuverbindung läßt sich dieser Ablauf ständig wiederholen. Der Abstand Sender zum Empfänger variert zwischen 1m - 4m ohne Hindernisse und die Empfängerantennen sind 90° versetzt.
Wegen der kalten Witterung habe ich bisher draußen keine Echtversuche gemacht. - Wer hat ein gleiches Problem bemerkt oder weiß, ob beim Fliegen möglicherweise diese Problem nicht auftritt? Ich würde mich über eine Antwort freuen.
 
Wenn es innen passiert, dann passiert es auch draussen. Bei einer Übersteuerung durch zu kleine Entfernung käme "Telemetrie verloren".
Welche Sensoren setzen denn genau aus? Das sieht man im Telemetriescreen, der Sensor ist dann in eckigen Klammern. Hat das Vario schon an einer anderen RX/TX Kombi funktioniert?
 

JAP

Neuer Benutzer
Bei der Kombination des R168 ( an SPort ) an RadioMaster Tx16s mit dem openXsensor-Vario erhalte ich zumindestens in meinem Bastelzimmer schon nach spätestens 1 Minute regelmäßig die Ansage "Sensor verloren". Nach Neuverbindung läßt sich dieser Ablauf ständig wiederholen. Der Abstand Sender zum Empfänger variert zwischen 1m - 4m ohne Hindernisse und die Empfängerantennen sind 90° versetzt.
Wegen der kalten Witterung habe ich bisher draußen keine Echtversuche gemacht. - Wer hat ein gleiches Problem bemerkt oder weiß, ob beim Fliegen möglicherweise diese Problem nicht auftritt? Ich würde mich über eine Antwort freuen.
Das Problem hatte ich auch am gleichen Empfänger R168 und OXSensor mit Vario und Spannungsmessung. Als Fernsteuerung war es allerdings eine QX7s. Welcher Sensor genau verloren ging habe ich nicht geschaut, war auch nicht wirklich fliegen damit, war ebenfalls in der Werkstatt. Meine mit dem gleichen OXS an früheren Empfängern das Problem nicht gehabt zu haben. Projekt ruht gerade wegen anderen Verpflichtungen, interessieren würde es mich trotzdem.
Beste Grüße
 
Wenn es innen passiert, dann passiert es auch draussen. Bei einer Übersteuerung durch zu kleine Entfernung käme "Telemetrie verloren".
Welche Sensoren setzen denn genau aus? Das sieht man im Telemetriescreen, der Sensor ist dann in eckigen Klammern. Hat das Vario schon an einer anderen RX/TX Kombi funktioniert?
Es fällt ausschließlich der openXsensor Vario mit der Höhenangabe aus, alle anderen Telemetriewerte des R168 Empfängers, incl. der Volt des Akkus erden uneingeschränkt angezeigt. 4 andere baugleicher OXS Varios, die aber auf Hott programmiert sind (für Graupner-Empfänger ), fallen auch während des Fliegens ( im letzten Jahr) nicht aus. Auch scheidet ein fehlerhafter R168 aus, weil das "sensor verloren" auch bei 3 weiteren R168 in oben beschriebener Form auftritt.
Vielleicht liegt es an der Empfänger Firmware V.1 - nur die kann ich mit der Radiomaster binden . Firmware V.2 ist nur für originale FrSky-Receiver. Oder hat jemand eine andere Idee?
 

r41065

Erfahrener Benutzer
Meinen R168 habe ich mit der FrSky v2 geflasht.
( an 3 Sendern: Taranis X9D/X9D+ )
1h Dauertest mit FLVSS, LQBB5 und OXS GPS hat keinerlei Aussetzer gezeigt...

Kontrolliere also ( nochmal ? ) die Verdrahtung vom OXS auf kalte Lötstellen bzw. Wackelkontakte am Anschluss...
Auch mit der original FCC v1 hatte ich keine Aussetzer...
Ralf
 
Vielleicht liegt es an der Empfänger Firmware V.1 - nur die kann ich mit der Radiomaster binden . Firmware V.2 ist nur für originale FrSky-Receiver. Oder hat jemand eine andere Idee?
Zieh mal das oXs Vario im laufenden Betrieb vom SPort ab und stecke es nach 30s wieder an, läuft es dann auch wieder oder braucht es einen kompletten Neustart?

Das ganze klingt für mich nicht nach einem Firmwareproblem, eventuell ist die SPort Beschaltung im R168 anders oder grenzwertig. Hast du ein Oszi, um den SPort Pegel zu beobachten, wenn das passiert?
 
Zieh mal das oXs Vario im laufenden Betrieb vom SPort ab und stecke es nach 30s wieder an, läuft es dann auch wieder oder braucht es einen kompletten Neustart?

Das ganze klingt für mich nicht nach einem Firmwareproblem, eventuell ist die SPort Beschaltung im R168 anders oder grenzwertig. Hast du ein Oszi, um den SPort Pegel zu beobachten, wenn das passiert?
Das Abziehen im laufenden Betrieb habe ich sehr häufig gemacht -> dann wird die Höhenangabe sofort nach dem Anstecken wieder angezeigt, um dann nach einiger Zeit ( paar Minuten) kommt wieder "Sensor verloren".
Ich habe schon überlegt, ob es daran liegt, daß ich einen Arduino pro mini 3,3V mit 8MHZ verbaut habe und nicht den mit 5V und 16MHZ - ich habe unter Github / OpenXsensor hierzu einen Beitrag gelesen: FrSky/S.Port Problems on Arduino 8MHz: Delay before send is missing, ... · Issue #63 · openXsensor/openXsensor . Hier wird ein Problem mit dem FrSky-SPort mit OXS und 3,3V Arduino pro mini angesprochen.
 
Da bist du sicher auf der richtigen Spur. Was du auch tun kannst, ist mal Pin7 statt 4 mit dem aktuellen Code für SPort zu verwenden und den im Code anzugeben (1.1 - Pin connected to Rx ). Möglicherweise hilft das auch in diesem Fall - ist aber nicht sehr wahrscheinlich.
 

Bussard

Erfahrener Benutzer
Da hat wer ein Schaltschema vom R168 auf RCG gepostet, ...
Gut gezeichnet von ddano007, nur die Versorgung mit 3.3V (A1117-3.3) war ihm wohl zu simpel für den Plan?

Ein ähnliches Problem hatte ich mit dem R168 im November schon mal, bin dem aber nicht konsequent nachgegangen, ein anderer R168 geht einwandfrei. Ich vermute wie Carbonator ein Pegelproblem, aber bin gespannt auf Erkenntnisse hier.
 
Zuletzt bearbeitet:
Das Fehlerbild scheint auf einen Drift (Aufladen) am SPort zu deuten, irgendwann wird vermutlich die Signalflanke nicht mehr erkannt. Wenn kein Oszi vorhanden ist, würde ich ganz stumpf mal einen 10-33kΩ Widerstand als Pullup vom SPort gegen 5V und dann mal als Pulldown gegen Masse schalten und testen. Den kann man provisorisch einfach mal in den SPort Stecker schieben.
 
Das Fehlerbild scheint auf einen Drift (Aufladen) am SPort zu deuten, irgendwann wird vermutlich die Signalflanke nicht mehr erkannt. Wenn kein Oszi vorhanden ist, würde ich ganz stumpf mal einen 10-33kΩ Widerstand als Pullup vom SPort gegen 5V und dann mal als Pulldown gegen Masse schalten und testen. Den kann man provisorisch einfach mal in den SPort Stecker schieben.
Das mit dem Pullup und Pulldown-Widerstand habe ich eben mal mit 22kΩ Widerstand ausprobiert: in der Pulldown-Schaltung leuchtet die LED des Arduino pro mini nicht mehr und in der Pullup-Verdrahtung leuchtet die LED, aber es wird überhaupt keine Höhe am Sender mehr angezeigt, d.h. der SPort findet kein Vario. Schade..........
 
Mich hat der R168 voll überzeugt. Habe mir 2STÜCK (11,89 pro Stück) bestellt welche nach 3Wochen gekommen sind. Die Spannungsjustierung wie sie vom Volker beschrieben wurde hat auch sofort geklappt. Ich würde den Empfänger sofort weiter empfehlen. Leider ist der Preis nunmehr schon bei 16,50Euro.
Gruß Bernd aus SFB
 

Amp-Toni

Neuer Benutzer
Hi Bernd,
Bist dann mit R 168 dann auch schon ausgiebig geflogen.
Vor allem hoch und weit weg ?
Hast du auch die beschriebenen Telemetrie Aussetzer. ?

Meine als Nr. 3-5 bestellten sind schon seit Wochen unterwegs, der am selben Tag mit anderer Transaktion bestellter R161 ist schon lange da.
Hat hier jemand Erfahrung mit Reklamationen diesbezgl. bei BG ?
Thomas
 

Bussard

Erfahrener Benutzer
...Meine als Nr. 3-5 bestellten sind schon seit Wochen unterwegs, ..
Die Händler bei BG und Aliexpress verkaufen auch Waren, die bei ihnen nicht vorrätig sind. Da muss man halt bei der Bestellung aufpassen, daß man das angegebene "Verschiffen"-Datum nicht fälschlicherweise für das voraussichtliche Lieferdatum hält. So kommen schnell mal 5 Wochen oder mehr zusammen.

Bei BG hatte ich erst eine Reklamation, mit 2 bis 3x Mail hin und her zur Klärung dann rasche Erledigung.
 
RCLogger

FPV1

Banggood

Banggood

Oben