STorM32 BGC: 3-Achsen STM32 Brushless Gimbal Controller

Hallo liebe Gemeinde!

Ich habe mir letztens eine NT IMU von Ensys eingebaut, welche auf meinem StorM32-Board V1.32 sauber funktioniert. Nun habe ich ein paar Fragen!:confused:

1. Leider läuft auf meinem Rechner und auf dem meiner Freundin nicht die BCG V2.29e (BETA) bzw. V2.30 an. Die BCG V2.20 läuft jedoch ohne Probleme an- woran kann das liegen? Fehlt mir irgendein Treiber? Das DOS Fenster (das schwarze Fenster) öffnet sich, aber es tut sich leider nichts. :(

2. Durch das Upgrade von I2C auf NT basierter IMU habe ich mir eine Performanceverbesserung versprochen, die leider nicht eingetreten ist. Da ich das StorM32 an meiner 3-Achs Gimbal nutze, war mir beispielsweise das "Fast Startup" wichtig, jedoch dauert es immer noch rund 7-10 Sekunden (unverändert zum I2C).

3. Bei schnellen links rechts Bewegungen (YAW-Achse) kommt das Board durcheinander und dreht sich dann hektisch hin und her, bis es wieder seine Position findet. Das Problem habe ich schon seitdem ich das Board haben und dachte zuerst, dass es eventuell daran liegt, dass das Board und die I2C auf einer gemeinsamen Achse (PITCH- überhalb der Kamera) liegen. Seitdem ich jedoch mein NT IMU habe, ist mein Board hinter der ROLL-Achse und meine NT IMU auf der PITCH-Achse (überhalb der Kamera). Hat jemand wertvolle Tipps für mich?

Danke euch! :)
 

OlliW

Erfahrener Benutzer
1. Ab v2.29 ist die Wifi Unterstützung hinzugekommen, und das macht wie es scheint leider bei Einigen Probleme. Leider macht es bei mir auf mehreren Rechnern (Win7 und Win10) gar keine Probleme, so dass ich das nicht debuggen kann. Heisst, ich würde das schon gerne lösen, bräuchte aber Hilfe.

2. Nö, "Performance" wird nicht besser, steht aber auch nirgends (da bräuchtest du T-STorM32). Fast Startup sollte allerdings schon deutlich schneller sein als bei der ollen I2C Version. Aber auch bei NT heisst das nicht augenblicklich (da bräuchtest du T-STorM32). Und wenn du wackelst hilft auch FastStartup nicht. Siehe bitte auch: http://www.olliw.eu/storm32bgc-wiki/STorM32_Parameters#Setup_Tab

3. siehe bitte http://www.olliw.eu/storm32bgc-wiki/Using_a_2nd_IMU. Für mich klingt das nicht so dass du dich daran hälst

:)
 
Grüß dich und vielen Dank für die schnelle Antwort! :cool:

Meine Freundin nutzt einen Windows 10 Laptop und ich einen Windows 7 Rechner ohne Wlan. Warum ist das Wlan für die funktion des Programms wichtig? Kann man es nicht deaktivieren und eine Version zum Download stellen? Entschuldige meine Unwissenheit. :???:

Punkt 2 und 3 lese ich mir jetzt durch- Danke! :)
 
Zuletzt bearbeitet:
Hab mir eben Punkt 3 angeschaut. Also ist das Aktuell falsch: 2017-09-14 16.45.28 Kopie.jpg

Also muss ich meine NT-IMU überhalb der Kamera lösen und über die YAW-Achse legen- richtig? :)

Nun interessiert es mich, wo ich ein T-STorM32 erwerben kann. ^^

Liebe Grüße!
 
Zuletzt bearbeitet:
Moin! :)

Habe vorhin mein NT IMU Überhalb der YAW-Achse montiert. Anschließend habe ich das Config Gimbal Tool der BCG V2.20 drüberlaufen lassen, damit sich die Achsen angleichen können. Bis zum Restart lief alles super, jedoch dreh sich dann die Roll- und die Pitch-Achse, bis das Board komisch piept und die Sotware einen Fehler ausgibt.

Liegt es nun daran, dass das Board nicht weiß, wo die Pitch- und die Roll-Achse position ist? Habe die Directions von Normal auf Reverse gestellt -> keine Veränderung. :(

Liebe Grüße! :)
 

OlliW

Erfahrener Benutzer
also, ohne infos kann mann nichts sagen
es klingt ganz stark danach das du irgendetwas nicht nach anleitung gemacht hast, was kann ich wie gesagt nicht sagen, ab es ist in 99.9% so
ich würde mal nachsehen ob wirklich pitch motor an pitch ist, und roll motor an roll (danach wieder gimbal config)
 

OlliW

Erfahrener Benutzer
also, ohne infos kann mann nichts sagen
es klingt ganz stark danach das du irgendetwas nicht nach anleitung gemacht hast, was kann ich wie gesagt nicht sagen, ab es ist in 99.9% so
ich würde mal nachsehen ob wirklich pitch motor an pitch ist, und roll motor an roll (danach wieder gimbal config)
 
Braucht die Pitch- bzw. Roll-Achse keine weitere IMU? Aktuell sitzt wie gesagt überhalb der Yaw-Achse (NT-IMU) und unterhalb der Yaw-Achse (Storm32 Controller) eine IMU. Woher soll der Controller wissen, was die Roll- bzw Pitch-Achse macht?

Liebe Grüße!
 
Hallo Leute,

Ich habe mal eine Frage. Mein Gimbal mit Board 1.3.1 stellt nach einiger Zeit einfach die Arbeit ein mal 1 Min mal 10 Min, scheinbar hängt sich da was weg. Wo kann ich ansetzen um den Fehler zu finden? Ist ein China Gimbal von Ebay als Neukauf. CRC Fehler kann ich keine sehen im Monitor. Sensorkabel und Motorkabel laufen durch Hohlwelle in den Motoren, schon ab Werk.

MFG SVen
 
Zuletzt bearbeitet:

OlliW

Erfahrener Benutzer
das kann natürlich 1000 Gründe haben
I2C Fehler sind der mit Abstand häufigste Grund bei deinem Gimbal, aber du sagst dass es das nicht ist. Sicher?
typischer Grund ist auch dass einfach die Imus falsch konfiguriert wurden => GimbalConfigTool durchlaufen
in einigen Fällen gab es auch Probleme mit "schlechten" Imus, die einfach zu viel Drift hatten
...
nachdem das anscheinend halbwegs reproduzierbar ist, einfach DataDisplay mitlaufen lassen, und das Stück vor dem Problem posten
 
Danke Olli, für deine Antwort.

Ja ist mich auch klar das es 1000 Gründe haben kann, daher ja auch der test mit dem Monitor, da sollte ja wenn was zu sehen sein, bevor er knallt, aber leider keinen einzigen CRC Fehler.
Ansich läuft alles gut, kein Drift, keine Ruckler, nur urplötzlich bleiben die Motoren stehen, quasi halten die Stellung bei, aber keine Regulierung der Achsen mehr. Erst wieder nach Reboot.
Und wirklich reproduzierbar ist das Verhalten auch nicht, ich hatte angenommen wenn ich irgend eine Aktion (walckeln, pitch o.ä.) mache wird der Fall ausgelöst, mal mache ich was, mal lasse ich alles in Ruhe, irgendwann aber steigt die Regulierung einfach aus.
Das macht die Suche des Fehler schwer.
Aber ich werde die IMUs noch mal Kalibrieren, sind sogar beide von Haus aus an gewesen.
Ich habe auch irgend wo gelesen das die Steckverbindung am de IMU unten gelötet sein sollte, aber wenn es schlechter Kontakt sein sollte, würde das doch zu sehen sein an den CRC Fehlern?
Naja ich werde am WE nicht mal drann setzen

MFG SVen
 
Hat denn schon jemand mal versucht über ein Script die "Motor Start Position" zu ändern?

Hintergrund wäre der, dass ich das Gimbal gerne einmal stehend und einmal hängend nutzen wollen würde!?
Dafür muss natürlich die Position (in meinem fall) der Rollachse angepasst werden. Im Optimalfall würde ich gern ein 2-Pos-Schalter am AUX anschließen und damit zwischen den Startpositionen wechseln.
Wenn einer weiß wie das geht darf er das gern hier in die Menge streuen!? :)

(wie man die Scripte steuert ist mir bewusst, nur ob es halt generell möglich ist die Startposition zu ändern)

Grüße, Jörg
 
Nabend,

ich habe aus einem youtube-video die Bauanleitung für einen Kameragimbal übernommen.
Empfohlen wurde der Stormcontroller, den ich dann bei gearbest erworben habe:
https://www.gearbest.com/fpv-system/pp_244970.html

Ich habe dann bei Github das Komplette Software-Zip geladen und wusste erstmal nicht recht, was ich aus der Menge an Versionen nehmen kann.

Letztendlich habe ich dann mit der Version 0.90 von OlliWs o323BGCTool eine Verbindung zum Controller bekommen.
Ein paar Einstellungen habe ich aus dem besagten Video übernommen und habe dann per "Configure Gimbal Tool" versucht den Gimbal einzurichten.

Das klappt leider NULL-NADA-GARNICHT ... mal bricht er mit Error ab, mal steht die Kamera am Ende schräg ... aber brauchbar ist bisher nix.

Ich habe in diesem THREAD und im Wiki mal ein wenig geblättert, finde aber nicht so richtig einen Ansatz, was ich mir mal ansehen sollte.

Die Firmware ist v0.90
Das Board ist v1.30 F10RC

Könnt ihr mir einen Schubs in die richtige Richtung geben?

Gibt es so etwas wie "vorne" bei dem Board? Sollte doch wurscht sein, oder?

Wäre für Hilfe echt dankbar ...

Cappy
 

OlliW

Erfahrener Benutzer
@sausarus:
Ich denke ich würe das Gimbal Config Tool für beide Situationen durch laufen, und dannach ansehen wo sich Änderungen ergeben haben, und diese dann ins Skript packen. Mit nur ne Startposition ist's nicht getan.

@cappy0815:
Wenn man nach Anleitung im Wiki vorgeht kann man da eigentlich nichts falsch machen ... allerding smuss man der Anleitung auch folgen!

Wenn da z.B. steht "You are now asked to position the gimbal and camera. The gimbal should be in its standard default position. Adjust the camera manually such that it is level and points to the forward direction of your copter.", und man das gelesen und verstanden hat, und dann auch noch das Bild gesehen hat, dann sollte so ne Frage wie "Gibt es so etwas wie "vorne" bei dem Board? Sollte doch wurscht sein, oder?" eigentlich nicht mehr auftauchen ... :)
 
Moin,

ich verstehe, was Du mir sagen willst und weiß, dass es manchmal nervig ist, wenn der 1000000. Neuling die Frage nach "wie geht das?" zum x-ten mal stellt.

Dieser Thread ist allerdings 178 Seiten lang und wenn man (noch) nur Bahnhof versteht, ist es wirklich schwer die relevanten Infos zu filtern.

Ich habe sowohl die in besagtem Video beschriebenen Schritte, als auch das Wiki durchgearbeitet und es hat dennoch nicht geklappt. Ich schliesse nicht aus, dass ich irgendwo zu doof bin oder was falsch mache.
Da ich nicht wusste wo ich ansetzten soll, war die Frage nach "vorne" eben eine unwarscheinliche Option, möglicherweise etwas direkt zu anfang falsch zu machen.

Die meisten Optionen und Begriffe aus dem Tool sagen mir nunmal nix.

Deine Antwort hat mich daher leider so null-komma-garnix weitergebracht.

Also nochmal ein paar (vermutlich dumme) Fragen:

Kann ich auf mein Board auch einfach eine v2.xx firmware schieben und könnte das was bringen?

Würde mich wirklich freuen, einen brauchbaren Tipp zu bekommen.

Danke
Cappy
 

OlliW

Erfahrener Benutzer
das der Thread einen nicht weiterbringt ist klar und verständlich ... aber deswegen gibt es auch ein Wiki
und wiederholte Fragen sind nicht das Problem

aber was erwartest du jetzt zu hören ... bei ner Aussage wie "Es klappt nicht, was mache ich falsch?" ?

Das Ziel des Wikis ist es ja nicht die wichtigen Schritten und bekannten Stolperfallen zu veschweigen, sondern ganz im Gegenteil ...

Antworten sind immer nur so gut wie die Fragen. :)

Kann ich auf mein Board auch einfach eine v2.xx firmware schieben und könnte das was bringen?
vermutlich nicht: http://www.olliw.eu/storm32bgc-wiki/Downloads
 
Nabend,

ich habe Heute nochmal viel rumprobiert.
Komischerweise lüft das Config-Tool nicht immer bis zum Ende, manchmal aber schon.

Dann habe ich mal alles um 90 Grad über Z gedreht und siehe da ... plötzlich geht es ...
Sehr eigenartig ... vielleicht gibt's ja doch ein "vorne" :p

Cappy
 
RCLogger

FPV1

Banggood

Banggood

Oben