STorM32 BGC: 3-Achsen STM32 Brushless Gimbal Controller

chebiqe

Erfahrener Benutzer
Am Kopter hängts halt, statt hier am Servotester mit rotem Stromkabel, am Empfänger. Trotz rotem Kabel leuchtet der Tester hier nicht. Warumauchimmer gibts am RC2+Pin nur 16mV, am andren RC Pin gar nix. -sollte ja auch egal sein. Strom von da brauchts nicht. Ausser zum Testen mitm Servotester.

IMG_20180406_175211[1].jpg
IMG_20180406_171541[1].jpg db.jpg DIP.jpg FF.jpg func.jpg GC.jpg PAN.jpg RCin.jpg setup.jpg
 

OlliW

Erfahrener Benutzer
ich wundere mich ja immer das keiner auf die Idee kommt den dicken Button "Share Settings" mal auszuprobieren. Vielleicht das nächste mal machen. :)

ansonsten, an den Parametern sehe ich nichts auffälliges

was ich nicht verstehe ist das mit dem "trotz rotem Kabel leuchtet der Tester nicht". Kann es sein dass du meinst das der Servotester über das rote Kabel mit Strom versorgt werden sollte und daher eine Betriebsled bei ihm leuchten sollte? Wenn dem so ist: RC0 ist KEIN Stromausgang, sondern ein Eingang ... also erstmal ServoTester mit Strom versorgen

im übrigen ist es eine gute Methode sich sein Board zu zerschiessen wenn man Stromleitungen an die falschen Pins anschliesst ... an Signalpins gehören nur Signalleitungen ... also, das rote Kabel hat da in jedem Fall nichts zu suchen
 

chebiqe

Erfahrener Benutzer
Oh, Ich denke simpel: 12 V gehen am Batterieanschluss rein, also muss am Pin was rauskommen. Da ich nie was reinleitete dürfte ja nix passiert sein.
Mag sein dass ich das mal wusste aber das meinste vergesse ich übern Winter.

Tja, auch mit stromführendem Servotester rührt sich nix.

Mein zweites TestStorm32 tut auch nix. Firmware mag dort auch keine drauf. Alle 'No Response'Fehlerquellen hab ich gecheckt.
...Ich kauf einfach ein neueres. SO!

--------------
AHHHH!!! dafür ist er!
Den ShareSettingsknopf hab ich nie beachtet. -Share klingt nach teilen, und das klingt nach facebook.

Danke für die schnellen Antworten. Leider sind Lösungen bei mir nicht so einfach. Für meine Fehlerteufel brauchts schon nen richtigen Exorzisten.


Zusatz: Dieses T-Strorm oder Storm 3.3 Board vom dem man munkelt: ist das nur eine Legende, eine Sage? Ich find im Internetz nix wo mans bestellen kann.
 
Zuletzt bearbeitet:

QuadCopterix

Erfahrener Benutzer
Hilfe, ich weiß einfach nicht mehr weiter.
Ich habe 3 Copter mit jeweils einem Storm32 (2x 2D- und einmal 3D-Gimbal) und habe bei allen dreien (!) das Problem das das Gimbal gelegentlich einfach "einfriert", dh. es funktioniert erstmal und nach einer undefinierten Zeit kann es sein, dass es plötzlich starr bleibt.
Bei dem 3D-Gimbal, das ich gerade in Betrieb nehmen möchte, ist es nun so schlimm, dass ich es fast nicht testen kann.
Mir ist aufgefallen, dass das Problem bei den beiden 2D-Gimbals erst aufgetreten ist als ich die PID erhöht habe.
Beispiel:
Einstellug alt (mit leichten Vibs bei stärkerem Wind):
Pitch P=3,0 I=105 D=0,045 Vmax=93
Roll P=3,0 I=225 D=0,045 Vmax=111

Einstellug neu (Gimbal friert gelegentlich ein, meißtens wenn Kamera 90° nach unten schaut):
Pitch P=6,5 I=450 D=0,060 Vmax=90
Roll P=7,0 I=450 D=0,060 Vmax=111

Alle drei Storm32 laufen mit Firmware V0.96
Hat jemand schon einmal das gleiche Problem gehabt? Irgend eine Idee?

Gruß Martin
 
Hallo Martin,

das Problem hatte ich auch. Du verwendest eine I2C IMU, nehm ich an. Entweder das IMU Kabel anders verlegen oder am besten direkt auf NT IMU umsteigen. I2C ist recht störanfällig.

Viele Grüße
Johannes
 

QuadCopterix

Erfahrener Benutzer
Hallo euch beiden und danke für eure Antworten. Scheint wohl doch mit dem IMU-Kabel zusammenzuhängen...
Ich habe nun die Kabelverlegung am 3D-Gimbal geändert und einen Ferritring integriert. Morgen werde ich es dann mal testen und dann berichten.

Gruß Martin
 
Moin,

habe ein Board von eBay.

Storm32 BGC 32Bit 3 Axis Brushless Gimbal Controller V1.31 DRV8313 Motor Driver | eBay

IMG_20180602_132717_copy[974].jpg IMG_20180602_132730_copy[973].jpg IMG_20180602_132752_copy[975].jpg

Mit der Firmware 0.90. Keine Ahnung ob die richtig ist???

firmware.JPG

Mein Problem, die Motoren fangen an zu kochen!!! Wodran kann so etwas liegen.
Hatte Problem, dass das ganze Gimbal am Vibrieren und zittern war wie verrückt. Habe dann etwas mit den Damping Werten gespielt und er ist jetzt rühig.

Aber die Motoren werden immer noch heiß.

Habt ihr ne Lösung für mich?

Lieben Gruß.
 

LSG

Erfahrener Benutzer
Hi von mir mal eine Feature-Anfrage. Nachdem de Controller seit einigen Jahren erfolgreich in meinem NEX Gimbal läuft, will ich mir noch ein handgehaltenes Gimbal bauen, das ich in bemannten Flugzeugen verwenden will. Daher die Frage, ob das Gimbal zum initiieren immer noch absolut ruhig sein muss oder ob es mittlerweile die Möglichkeit gibt, das Gimbal auch bei leichten Vibration zu starten und eventuell vorher am Boden zu initiieren.

Danke und schöne Grüße von einem glücklichen Storm32-Nutzer
 

QuadCopterix

Erfahrener Benutzer
Nachdem ich das IMU-Kabel anders verlegt habe und den Ferritkern wieder eingebaut habe, ist das Problem vergessen, das Gimbal "friert" nicht mehr ein.
Die Kabelverlegung wirkt sich wirklich elementar auf die Funktion aus!
Danke nochmal für die Hilfe

Gruß Martin
 
Hallo zusammen,
ich hab auch mal wieder ein Problem. Mein Gimbal ist sehr, sehr selten im Einsatz. Und jedes Mal, wenn ich es brauch funktioniert er nicht mehr. Dann bleibt er bei LEVEL bzw. RELEVEL hängen. Das tut er dann natürlich auch im CalibrationTool. Dann hilft nur mal komplett auseinandernehmen und wieder zusammenbauen, weiter nix. Nur das jedes Mal machen zu müssen geht mir ziemlich auf die Nerven. Weiß einer woran das liegen kann. Ich nehme an, dass einer der Motoren keine ordentlichen Kontakt zum Board hat. Aber nachdem ich alles auseinander genommen hab funzt es wieder. Dann leg ich das Gimbal in die Ecke und hol es 3 Wochen später wieder raus und schon geht nix mehr. Da kann sich doch nicht jedes Mal der Kontakt verabschieden!?:unsure:

Hoffe jemand kann mit der holprigen Beschreibung etwas anfangen.
Danke!

Viele Grüße
Johannes
 
Hallo zusammen,

zwischenzeitlich hab ich mir aus Zeitdruck einen Rollei Steady Butler Action gekauft. Leider funktioniert der nicht wirklich gut, weiß nicht ob das an der Hero 4 liegt oder ob ich ein Montagsmodell bekommen hab, jedenfalls hab ich ihn zurückgeschickt. Die Videos waren extrem verwackelt, das wäre ohne Gimbal nicht viel schlechter gewesen.
Dann hab ich mir gedacht ich muss vielleicht doch an meinem Eigenbau weiterbasteln. Nachdem ich ja scheinbar ein Kontaktproblem hatte (???) hab ich alle Steckverbindungen entfernt und hab alles fest verlötet.

Als absoluter Lötanfänger bin ich froh, dass schon mal die LEDs leuchten :giggle: Um genau zu sein, der Gimbal macht genau die gleichen Faxen wie vorher. Bei LEVEL dreht er die Pitch-Achse 3x schlagartig um ca. 30° nach oben, dann werden die Motoren abgeschaltet. das war´s dann. Natürlich hab ich auch das Wiki zurate gezogen, nachdem ja auch im Config-Tool der Link dorthin erscheint. Was läuft hier schief? Eines der Motorenkabel gebrochen? Hat jemand noch einen Rat?

Ansonsten werde ich das Projekt wohl oder übel langsam beerdigen müssen, was schade wäre, weil wenn er mal funktioniert hat war die Stabilisierung richtig gut.:cautious:

Danke euch schon mal!

Viele Grüße
Johannes
 

olex

Der Testpilot
Ich belebe den Thread mal etwas wieder, vielleicht gibt es ja noch den einen oder anderen Nutzer oder sogar @OlliW selbst hier :)

Habe einen STorM32 BGC als Kern in einem selbst entwickelten Gimbal auf meinem VTOL Mini Talon verwendet. Ein paar Details im Thread: Mini Talon VTOL (Arduplane Quadplane)

Bilder vom Gimbal:

WhatsApp Image 2019-03-05 at 22.10.24.jpeg WhatsApp Image 2019-03-09 at 17.55.48.jpeg WhatsApp Image 2019-03-09 at 17.55.49.jpeg WhatsApp Image 2019-03-09 at 17.55.49(1).jpeg

Habe das Ganze nach der Anleitung im Wiki grundsätzlich zum Laufen gebracht, und stehe jetzt vor dem PID Tuning. Mit den Standardwerten rastet das Gimbal völlig aus. Mit allen PID Werten am Minimum läuft es sauber, führt aber nur leicht geruckelt und mit minimaler Verzögerung nach (nicht merkbar von außen, aber im Kamerabild eindeutig zu sehen). Wenn ich die Werte nach den üblichen Verfahren erhöhe, läuft es besser, aber bekommt selbstinduzierte Vibrationen in einigen Lagen. Es scheint primär die Pitch-Achse "schuld" zu sein, die auch leider momentan am schlechtesten balanciert ist wegen Fehler im CAD (falsche Gewichte der Kamera und Motoren eingetragen...).

Liege ich richtig in der Annahme, dass ich die Gimbalarme wohl umzeichnen und neu drucken muss um die Balance möglichst perfekt hinzukriegen, bevor ich mich weiter an den PIDs versuche? Habe erst naiv angenommen dass die etwas überdimensionierten Motoren das Bisschen Ungleichgewicht problemlos überwinden, dem scheint wohl aber nicht so...
 

OlliW

Erfahrener Benutzer
Hallo Olex
yo, mich gibt's noch LOL

zu deinem Projekt: wirklich sehr schönes Projekt, aber: sehr schwierig für uns DIYler

zunächst zum Prinzip wie ein Gimbal funktioniert: Wenn du die Gimbalhalterung hinundher schwenkst sollten die Motoren im Idealfall NICHTS zu tun haben! Dann funktioniert ein Gimbal gut. Es ist also genau anders herum als of geglaubt wird, das die Motoren die Kamera ausrichten würden (mit der beliebten Schlußfolgerung das stärkere Motoren besser wären). Im Idealfall macht das alleine die Trägheit (das Trägheitsmoment) der Kamera, die Kamera in Position zu halten.

Das Problem: Je kleiner die Kamera desto mehr schlagen alle Störfaktoren wie Reibung in den Achsen, Kabel usw zu.

Du kannst das mit deinem Gimbal gerne mal ausprobieren: Lasse die Motoren stromlos und bewege die Gimbalhalterung hinundher. I wette darauf das sich deine Kamera immer mit der Gimbalhalterung mitbewegt und nie und nimmer in einer Anfangslage bleibt. Dir wird der Grund auch schnell einleuchten, das ist wegen den ganzen Reibungen.

Damit weisst du aber auch was du verbessern musst, bzw. müsstest, denn wie gesagt ist das für uns DIYler schwierig.

A-und-O sind meistens die Motoren. Leider gibt es keine guten kleinen Gimbalmotoren (für uns DIYler).

Bei deinem Aufbau kommt noch das Problem hinzu dass du eine Roll-Pitch-Yaw Anordnung hast. Die wird vom STorM32 - aus verschiedenen (guten!?) Gründen nicht unterstützt. STorM32 will eine Pitch-Roll-Yaw Anordnung.

Auf Planes kommt noch das Problem der üblicherweise relativ hohen Fluggeschwindigkeit hinzu. Auch die Luft zerrt am Gimbal, und das meistens eher turbulent als schön gleichmässig. So ein langes dickes freistehendes Kabel wie das von der Kamera ist das ideale Opfer für die Luft, ist "tödlich".

In meinen Versuchen habe ich gesehen das es für kleine Gimbals häufig besser ist eine niedrige Spannung zu verwenden, z.B. 7 V (das STorM32 kann leider so wie es ist nicht an 5V arbeiten, muss ich mal ändern)

Ich weis, ich mache vermutlich nicht gerade Hoffnung, aber das ist meine erliche Meinung, dass du einige Zeit ins Experimentieren stecken müssen wirst.

Olli
 

olex

Der Testpilot
Vielen Dank für die Antwort! Mir war schon klar dass das kein einfaches Projekt wird, aber die Hinweise sind alle sehr willkommen, und das wird mir sicherlich weiterhelfen.

Schade dass Roll-Pitch-Yaw nicht unterstützt wird. Das macht die Kabelführung erheblich einfacher. Ich werde versuchen auf Pitch-Roll-Yaw umzubauen, allerdings wird das Kabel der Split sehr im Weg sein, wenn die Pitchachse nach oben schwenkt - mal sehen wie ich das lösen kann.

Spannung ist auch ein sehr guter Hinweis. Bisher habe ich geplant den Gimbal mit der Hauptspannung (4S) zu betreiben, und auch mit einem 16V Netzteil getestet/getuned. Allerdings steht mir auf dem Flieger ein sehr guter 9V 3A BEC zur Verfügung der momentan nur den Videosender versorgt - dann werde ich wohl eher Strom davon nehmen, damit ist die Spannung stabil und auch niedriger, wenn das mit dem kleineren Aufbau zu besseren Ergebnissen verhilft.

Am Balancing werde ich natürlich auch noch arbeiten. Die Beschreibung mit der Trägheit der Kamera leuchtet ein; leider ergibt es dann auch Sinn, dass die sehr leichte Kamera das Ganze schwerer macht, da ihre Trägheit noch nicht mal das Haltemoment der stromlosen Motoren überwindet. Ich versuche es so optimal wie möglich zu gestalten, und tune das Ganze im Anschluss nochmal.

Ich melde mich mit den Ergebnissen, sobald ich was habe. Diesen Sonntag ist schönes Flugwetter versprochen, vielleicht kriege ich bis dahin einen Zustand hin den man mal in die Luft bringen kann :)
 

OlliW

Erfahrener Benutzer
Schade dass Roll-Pitch-Yaw nicht unterstützt wird. Das macht die Kabelführung erheblich einfacher. Ich werde versuchen auf Pitch-Roll-Yaw umzubauen, allerdings wird das Kabel der Split sehr im Weg sein, wenn die Pitchachse nach oben schwenkt - mal sehen wie ich das lösen kann.
du siehst es nur falsch: Die Kabelführung ist wirklich dein geringstes Problem. Dieser Baumstam (so sieht es aus Sicht des Gimbals aus) muß weg. Und muss aus der Luft raus.

In einem der STorM32 threads by rcgroups hat jemand ein Swift (?) Gimbal gebaut, das gar nicht so schlecht ging, jedenfalls den Videos nach. Habe mal danach gesucht und auf die Schnelle das gefunden:
RC Groups - View Single Post - STorM32-NT BGC
RC Groups - View Single Post - STorM32-NT BGC
dazu hat er aber auch die von mir benutzten PSM motoren benutzt, so wie ich das sehe
das ist allerdings auch schon das Einizge mir bekannte "kleine Kamera" Gimbal Projekt das halbwegs zu funktionieren schien, jedenfalls soweit meine Errinnerung reicht.
es könnte sich lohnen noch ein bisschen in den Threads zu suchen
 
Hallo zusammen,
das Thema Gimbal lässt mich einfach nicht los. :rot:
Irgendwie bin ich diese Woche wieder über meinen unfertigen GoPro Handheld Gimbal gestolpert. Kaputt machen konnte ich ja nichts mehr, also hab ich alles wieder zerlegt und dann die Motoren mal durchgeprüft und siehe da, der Pitch Motor hat scheinbar einen Kabelbruch. Zusätzlich ist mir eine durchgescheuerte Stelle am IMU Kabel aufgefallen, sieht auch nicht gesund aus:cautious:

Nun hab ich mal wieder ein paar Fragen:
- Gibt es mittlerweile irgendwelche neuen empfehlenswerten Motoren, am besten mit Slip Ring oder großer Hohlwelle (> 5 mm)? Bei meinen Motoren (T-Motor GB2208) zwickt es schon ein bisschen, vor allem beim Yaw Motor. Habe gesehen, dass EagleEi einen DYS GBM 2608 mit Slipring für Yaw einsetzt, den Olli aber wegen des Coggings nicht empfiehlt. Jetzt habe ich heute noch EMAX GB2806 und GB2210 gesehen, hat damit jemand Erfahrung?
- T-Storm interessiert mich ziemlich. Ist das für einen Elektronik-Noob wie mich überhaupt geeignet, oder sollte ich mir das schnell wieder aus dem Kopf schlagen?

Bevor der Post zu lang wird hör ich hier lieber erstmal auf. :engel:
Danke schon mal für eure Antworten!

Viele Grüße
Johannes
 

OlliW

Erfahrener Benutzer
Motoren für GoPro Gimbals sind ein echtes Problem geworden ... ich kenne eigentlich nichts Gutes was auch noch bezahlbar ist ... möglicherweise die RCTimer2804, aber ??? Oder die Motoren die auch beim HAKRC gimbal benutzt werden, habe ich selber noch nicht getestet (habe zwar ein paar da aber ...), aber was man so hört und liest sind die nicht die Schlechtesten ... vielleicht sind die im Moment tatsächlich die beste Wahl !?

lass die Finger vom GB2608 ... ich schreibe was ich schreibe manchmal sogar mit Grund

generel lass ich mittlerweile meine Finger von allen GB's ... bin mit keinem bisher glücklich geworden ... obwohl der Preis was anderes andeuten will

slipring kannst du glaube ich bei der Motorgröße vergessen ... den kleinesten Slipring den ich kenne hat 6mm Durchmesser, und wenn du den in der Hand hälst fällt er quasi von selbst auseinander ... vetrauenserweckend ist für mich anders

für ein HandHeld ist ein slipring zum Glück auch verschmerzbar (IMHO hat das auch fast keines der käuflichen GoPro Gimbals)

wenn die Kabel in der Durchführung reiben ist das nie gut, schon weil Reibung = schlechte Controllerperformance, zum Glück gibts aber auch dünne Kabel und nicht nur Dicke ...

T-STorM32: wie bei Allem im Leben hängt es nicht nur davon ab wieviel Ahnung man bereits hat, sondern vorallem auch davon wie hartnäckig und ausdauerned man beim Neuen ist ... ;)

T-STorM32 ist zweifelsohne schwieriger schon alleine weil mehr Schritte zum Konfigurieren durchlaufen werden müsse, mehr Schritte = mehr Möglichkeiten etwas falsch zu machen. Das lässt sich aber lösen und soweit mir bekannt ist es daran noch nicht gescheitert. Es ist auch deutlich teurer, und der Frust wenn es nicht klappt evtl dementsprechend größer. Die aber - IMHO - größte Hürde sind die eigenen mechanischen Fertigungsmöglichkeiten. Der Magnetring muss angebracht werden, und die Motortreiberplatine auch. Ich z.B. scheitere regelmässig am Magnetring, deswegen habe ich auch die HAKRC Motoren nie getestet, keine Ahnung wie ich mit meinen Mitteln die Magnetringe anbringen soll, und deswegen mag ich die RCTimer2804, weil da der MAgnetring perfekt auf die Hohlwelle passt, aufstecken, festkleben, fertig. Andere kaufen sich Motoren mit Magnetring und AS5048 Encoderplatine, scheitern dann aber am Löten. Usw. Das sind so die Hürden. Hängt also vorallem von deiner Werkstatt ab.

Es ist aber anscheinend machbar, siehe als Beispiel funthings's GoPro Gimbal: T-STorM32: The best STorM32 ever !? - Page 22 - RC Groups. Schade das er das Aluizeugs nicht als Kleinserie anbietete ... das hätte ich auch gerne LOL (obwohl, vielleicht sollte man ihn ansprechen ... wenn es mehrere Interessenten gibt ...)
 
Hallo Olli,

danke für die wirklich ausführliche Antwort!
Das mit den Motoren hatte ich schon befürchtet. Naja vielleicht komm ich ja mit denen, die ich da hab zurecht. Die Kabel von IMU, Pitch- und Roll-Motor passen fast nicht durch die Mini Hohlwelle der GB2208 auf der Yaw-Achse:unsure:
Also wenn ich das so lese, traue ich mich erstmal nicht an T-Storm ran, werde es aber sicher noch weiter verfolgen. Ich bin schon mit dem aktuellen Projekt mit Storm-NT mehrfach an meine nervlichen Grenzen gestoßeno_O
Die aufgeriebenen Kabel kommen bei meiner Konstruktion wahrscheinlich daher, dass ich alles möglichst kompakt und komplett ohne sichtbare Kabel bauen wollte. Muss denen irgendwie doch mehr Platz gönnen. Jetzt muss ich mir erstmal überlegen welche Motoren ich einsetzen will, dann kann ich den Gimbal umkonstruieren und dann geht´s mal wieder ans Drucken. Das dauert wieder einige Wochen.

Viele Grüße
Johannes
 
RCLogger

FPV1

Banggood

Banggood

Oben