RCLogger

Banggood

Foxtech

Flyduino.net

Pidso.com

FPV1.DE
Seite 180 von 180 ErsteErste ... 80 130 170 178 179 180
Ergebnis 1.791 bis 1.798 von 1798

Thema: STorM32 BGC: 3-Achsen STM32 Brushless Gimbal Controller

  1. #1791
    Zitat Zitat von JohnHaens Beitrag anzeigen
    Das klingt natürlich nicht so, als ob das so gehört, aber deshalb melde ich mich ja hier auch.

    Konnte gestern das Gimbal mal komplett zerlegen. Hab dann beim Zusammenbau die Motoren durchgetauscht und die Kabel einfach außen herumhängen lassen. Jetzt funktioniert alles soweit. Scheinbar hatte der Yaw Motor irgendwie keinen richtigen Kontakt zum Board, oder was auch immer. Jetzt muss ich noch ein paar Teile Drucken und dann geht´s wieder ans Feintuning, in der Hoffnung, dass es diesmal besser funktioniert als mit den großen Motoren.

    Melde mich, wenn das Gimbal läuft (oder natürlich wenn ich wieder mal nicht weiterkomme)

    VG
    Johannes

    Hallo zusammen,

    endlich bin ich mal wieder dazu gekommen an meinem Gimbal weiter zu machen. Hab natürlich die neueste Firmware geflasht (2.35e) und alles nochmal von vorne eingestellt. Ein paar Ruckler sind schon noch ab und zu zu sehen, aber jetzt bin ich eigentlich soweit zufrieden. Könnt euch ja mal das Testvideo anschauen und vielleicht eure Meinung dazu abgeben. Vielleicht hat ja der ein oder andere noch einen Tipp wie ich es besser hinbekommen könnte.
    Hier sind meine Parameter:
    https://drive.google.com/open?id=1KU...oCvYqkaMsERgXy

    Und hier das Testvideo:
    https://drive.google.com/open?id=1aU...M9n5yzgMGIFr_E


    Ohne eure Hilfe (besonders natürlich von Olli) hätte ich schon lange aufgegeben. Danke dafür!

    Viele Grüße
    Johannes

  2. #1792
    Guten Morgen,

    Mein Storm32-NT hat Stabilisierungsprobleme, und zwar 'wackeln' die Achsen etwas herum, d.h. es kommt zu grösseren Abweichungen von der Soll-Position (vor allem Pitch-Achse), obwohl die Stabilisierung ansonsten ganz okay funktioniert:


    http://www.youtube.com/watch?v=nga8hWP6NmQ



    Woran kann das liegen? PIDs? Kalibrierung (habe ich eigentlich schon erneut durchgeführt)? Aussentemperatur?

  3. #1793
    @ JohnHaens
    na wird ja

    @ Upgrade 08/15
    du meinst wohl diesed langsame "Pumpen" in Pitch ... sieht wirklich komisch aus ... ich denke ich würde mal die Einstellungen im Pan-Tab für Pitch überprüfen. Ich glaube es gab auch mal Fälle wo so was Ähnliches am RC Eingangsignal lag, dass das einiges Jitter hatte ... also wenn du RcInput für Pitch hast ...
    PIDs oder Kalibrierung würde ich mal nicht so vermuten

    und weil ich gerade schon mal hier eingelogt bin, zwei jüngere Videos zum T-STorM32:

    http://www.youtube.com/watch?v=z03PkDf0R-0


    http://www.youtube.com/watch?v=l8rz78kDWNY


  4. #1794
    Zitat Zitat von OlliW Beitrag anzeigen
    @ Upgrade 08/15
    du meinst wohl diesed langsame "Pumpen" in Pitch ... sieht wirklich komisch aus ... ich denke ich würde mal die Einstellungen im Pan-Tab für Pitch überprüfen. Ich glaube es gab auch mal Fälle wo so was Ähnliches am RC Eingangsignal lag, dass das einiges Jitter hatte ... also wenn du RcInput für Pitch hast ...
    PIDs oder Kalibrierung würde ich mal nicht so vermuten
    Ja, pitch-pan habe ich auf einem RcInput. Ich verwendete bisher den S2 Poti der Taranis für Pitch (und S1 für Roll). Ich habe nun von s2 auf den rechten hinteren Schieberegler gewechselt - der 'Trockentest' am Boden verlief so weit gut.
    Vermutlich ist der S2 Poti der Taranis defekt.

    Vielen Dank für deine Hilfe!

  5. #1795
    du kannst auch noch mit RcDeadBand und RcHysteresis rumspielen. Das Deadband wirkt um Null herum, wenn du das größer machst dann schluckt er mehr vom Jitter. Die Hysteresis wirkt wenn man weg von der Null ist, akzeptiert dann ne Änderung nur wenn sie groß genug ist

  6. #1796
    Zitat Zitat von OlliW Beitrag anzeigen
    du kannst auch noch mit RcDeadBand und RcHysteresis rumspielen. Das Deadband wirkt um Null herum, wenn du das größer machst dann schluckt er mehr vom Jitter. Die Hysteresis wirkt wenn man weg von der Null ist, akzeptiert dann ne Änderung nur wenn sie groß genug ist
    Ich habe zuerst versucht, die beiden Werte um je 5us zu erhöhen, aber das hat nicht funktioniert.

  7. #1797
    ...und wie das halt so ist; sobald das eine Problem gelöst ist, taucht das nächste auf: Wenn ich den Kopter seitwärts (oder auch vor/rückwärts) anstelle, bewegt sich das Gimbal langsam mit, beinahe als ob eine 'nachführ-Funktion' aktiviert wäre.

    http://www.youtube.com/watch?v=a4VpTvEZ7FI


    Kann ich davon ausgehen, dass dies an einer schlechten Kalibrierung liegt? Und falls ja, kann ich die Kalibrierung durchführen, in dem ich den Sensor an einen Metallblock klebe, wobei der Metallblock ein (schwaches) Magnet enthält? D.h. stört das Magnet den Kalibrierungsvorgang?


    Aber abgesehen davon, bin ich mit dem Gimbal sehr zufrieden. Die Videos werden - bis auf ein leichtes zittern, das sich gut entfernen lässt - sehr stabil:

    http://www.youtube.com/watch?v=HmLWIvKUvBo


    Und hier mit entferntem Zittern (sieht schon fast wie ein Standbild aus) :

    http://www.youtube.com/watch?v=x0zoQeeTtLw

  8. #1798
    Zitat Zitat von Upgrade 08/15 Beitrag anzeigen
    taucht das nächste auf: Wenn ich den Kopter seitwärts (oder auch vor/rückwärts) anstelle, bewegt sich das Gimbal langsam mit, beinahe als ob eine 'nachführ-Funktion' aktiviert wäre.
    das ist kein "Problme" sondern ist Prinzip-bedingt so, "oben" und "unten" wird Anhand der Beschleunigung bestimmt, und wenn die eben nicht nur Gravitation ist, geht's schief. Siehe dir dazu unbedingt das 2te Video in Post #1793 and, und danach das 1te Video, am Ende hat es eine Erklärung

    das leichte Zittern ist häufig ein Problem. Das lässt sich weitgehend wegbekommen, allerdings muss man dann echt Arbeit ins Gimbal investieren. Es scheint dass da das T-STorM32, mit Encodern, deutlich besser wegkommt.
    Geändert von OlliW (14.02.2018 um 20:41 Uhr)

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •